Alesis QS8.1 No Characters displayed, no response to keys or buttons!


Joined
May 24, 2019
Messages
1
Reaction score
0
Hi, I just bought an "as is" SQ8.1. When I brought it home I noticed that when powered on the display was illuminated, but instead of characters being displayed only the left most top line dash was displayed. I tested the internal coin call and it measures 3.2v. I tried the 01 + 03 reset and it worked the first time I tried it by bringing up the proper display but no buttoms pushed resulted in any response! After turning the unit Off, the same dash in the first line of the display returned, but the 01+03 combo did nothing. Sometimes when I turn it on the display comes back but it is locked and I must turn the unit off to try again. The power switch cycle sometimes results in something being displayed but it seems to be successful less and less frequently as time goes by.
Does this sound like the Micro reset issue? I have the Alesis Repair manual (for the QS6, 7 and 8) but there are no schematics in the section with that title.
Anyone have any ideas on a possible fix?
Or where I could find schematics for the QS8.1?
Any thoughts or help would be greatly appreciated!

Mitch
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top