Help with my Roland D-50 PLEASE!! DISPLAY PROBLEM


Joined
Nov 7, 2019
Messages
2
Reaction score
0
Hello everyone, I'm having a very strange problem with my Roland D-50, I turned it on today and I can't see any characters on the display, the display is lit, you can see the green light on the whole display but there's no characters. And weird thing is that the sounds are still there, if I change banks and patches you can hear all the different sounds even if I put in a card I can hear those sounds too. I just can't see which sound it's selected or anything at all. I've heard other people complaining about no display but also no sound, but I do get all the sounds so I really don't know what the problem is. I've attached a picture
IMG_20191107_170326.jpg
 
Ad

Advertisements

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
9,906
Reaction score
4,232
Location
GTA, Canada
It could be dirty contacts on a ribbon connector. If you're up to it. CAREFULLY open it up,, remove the ribbon connectors and spray them with DeOxit contact cleaner then CAREFULLY reseat the connectors.

Take lots of digital photos during disassembly so that you don't accidentally reverse or misplace any connectors.

Gary ;)
 
Joined
Oct 19, 2020
Messages
3
Reaction score
0
[QUOTE = "Matron117, publicación: 204429, miembro: 11630"]
Hola a todos, tengo un problema muy extraño con mi Roland D-50, lo encendí hoy y no veo ningún carácter en la pantalla, la pantalla está encendida, se puede ver la luz verde en toda la pantalla pero no hay personajes. Y lo extraño es que los sonidos siguen ahí, si cambio los bancos y los patches, puedes escuchar todos los sonidos diferentes, incluso si coloco una tarjeta, también puedo escuchar esos sonidos. Simplemente no puedo ver qué sonido está seleccionado ni nada en absoluto. He escuchado a otras personas quejarse de que no hay pantalla pero tampoco sonido, pero obtengo todos los sonidos, así que realmente no sé cuál es el problema. He adjuntado una fotoView attachment 1629
[/CITAR]
 
Ad

Advertisements

Joined
Nov 7, 2019
Messages
2
Reaction score
0
Hola disculpen tengo el mismo problema alguien tendra la solucion gracias
Hola amigo, yo resolví el problema simplemente reemplazando la batería por una nueva, lo hice hace varios meses atrás y hasta ahorita ya no he vuelto a tener ese problema. Lo único malo es que cuando cambias la batería por una nueva todos los sonidos del teclado se borran y tienes que volverlos a instalar ya sea con una tarjeta o por medio de sysex. Buena suerte.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top