How to make keyboards onto separate channels


Joined
Apr 26, 2020
Messages
2
Reaction score
0
Hello,

I have an iMac computer that I run my keyboards through using USB. I have an iRigKeys I/O from IK Multimedia and an M-Audio Keystation 49es. I am using the IK Multimedia program Hammond B3-X and I want to use one keyboard for the upper deck in the program and one for the lower deck. I need someone to walk me through the connection process so I can understand why this isn't working. I'v already tried Ch 1 and Ch 2, but they both keep playing the upper deck in the program. Any help on this would be greatly appreciated. I would like to utilize my program to it's fullest. Thank you in advance for any and all help.

Matt
 
Ad

Advertisements

Joined
Sep 6, 2017
Messages
3,232
Reaction score
2,070
Location
Lancashire, UK.
Welcome.

How are you connecting your keyboards to your iMac?

Is there a Manual for the B3-X? I cannot find one on the not registered section of the iRig website.

Also do you have Main Stage installed on your iMac?
 
Joined
Apr 26, 2020
Messages
2
Reaction score
0
Welcome.

How are you connecting your keyboards to your iMac?

Is there a Manual for the B3-X? I cannot find one on the not registered section of the iRig website.

Also do you have Main Stage installed on your iMac?
I am connecting the keyboards through USB ports. The B3-X set up is the upper manual (deck) is on midi channel 1 and the lower manual (deck) is on midi channel 2 and the pedals are on midi channel 3. The problem is, that both keyboards only play the upper deck in the program. I was told that one keyboard should be the "master" and the other the "slave" so that they would be used in the 1 & 2 positions in the midi chain. This doesn't seem to be happening and I'm getting a little frustrated.
 
Joined
Sep 6, 2017
Messages
3,232
Reaction score
2,070
Location
Lancashire, UK.
Have you looked for a solution on the iRig Forum?

A member there has your setup and it works with upper and lower on different keyboards.

But

They just get Upper on both when they have other software running, they do not seem to have posted a solution as yet.

I did a quick search over there and there are 70 threads on the B3X, hence you may wish to head over there to check that forum out.

As it is I there has not been a lot of discussion here about the B3X app in either iMac or iPad versions.

I use Galileo 2 on my iPad which is way way less expensive.
 
Joined
Jun 26, 2010
Messages
627
Reaction score
289
Sorry if this is too obvious, but from your post, it sounds like both your keyboards are transmitting on the default MIDI channel 1, you need to change one of them to transmit on MIDI channel 2. It's not a connection issue, it's a setting you have to make on the keyboard itself to tell it you want it to send on channel 2 instead of channel 1.
 
Ad

Advertisements

Joined
Apr 4, 2012
Messages
749
Reaction score
301
Sorry if this is too obvious, but from your post, it sounds like both your keyboards are transmitting on the default MIDI channel 1, you need to change one of them to transmit on MIDI channel 2. It's not a connection issue, it's a setting you have to make on the keyboard itself to tell it you want it to send on channel 2 instead of channel 1.
This!

Sounds as though both keyboards are transmitting keybed information on channel 1, therefore either keyboard that you play is sending data on channel 1 which is being converted to the "upper manual". For the keyboard that you want to control the lower manual ensure that the keyboard itself is sending on midi channel 2, which is a keyboard setting, not an IMac computer setting. Let's say the M-Audio Keystation 49 keyboard is the keyboard that is playing the lower manual (you didn't say above which keyboard is playing the lower channel, so I'm guessing), check the user manual of that keyboard and determine how you change the keyboard settings to send its keyboard data via MIDI on Channel 2. Once you set the keyboard itself to send on MIDI channel 2 you will begin to hear that keyboard play the lower manual.

It's like an old fashion radio, you have the radio set to 93.7 (the computer program) but the station is sending on 94.1 (the keyboard). The keyboard and the program BOTH have to be set to send and receive on the same radio station in order for the radio to transmit the music to actually hear the music. You've set the program to receive upper on channel 1 and lower on channel 2 but you haven't told the keyboard sending lower manual data to SEND on channel 2. 99% of all keyboard are defaulted to channel 1, so you have to make the change to channel 2.

From the M Audio owners manual:

1588169123870.png


For the IRig keyboard:

1588169280118.png


Whichever keyboard above is used for the lower manual needs to be send on midi channel 2.
 
Last edited:
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top