Midi keys not playing (sometimes)


Joined
Oct 26, 2019
Messages
2
Reaction score
1
Hi there!

Not quite sure when this started, however is the case, when I play C5 or D5, there is midi signal showing, yet there is no sound. Sometimes they do play, although mostly they don't.
I have tried various sequencer software and there is no difference.

Anyone know what could be happening? :oops:
 
Ad

Advertisements

SeaGtGruff

I meant to play that note!
Moderator
Joined
Jun 6, 2014
Messages
2,744
Reaction score
1,153
What model keyboard is it?

Have you tried looking at the output in a MIDI monitor? MIDI sequencers and DAWs often have a monitor view or MIDI event listing, and the list might tell you if there's anything funny about the signals being sent-- such as, if the keys are sending Note On events but no corresponding Note Off events, or vice versa, or the velocity value in the Note On event is 0, or anything else that doesn't look right.

Sometimes opening the keyboard's case and cleaning the keyboard contacts can help, but don't try that unless you know what you're doing, and be very careful about what you try to clean the contacts with. You might be able to find a video on YouTube that shows someone doing this.
 
Joined
Oct 26, 2019
Messages
2
Reaction score
1
What model keyboard is it?

Have you tried looking at the output in a MIDI monitor? MIDI sequencers and DAWs often have a monitor view or MIDI event listing, and the list might tell you if there's anything funny about the signals being sent-- such as, if the keys are sending Note On events but no corresponding Note Off events, or vice versa, or the velocity value in the Note On event is 0, or anything else that doesn't look right.

Sometimes opening the keyboard's case and cleaning the keyboard contacts can help, but don't try that unless you know what you're doing, and be very careful about what you try to clean the contacts with. You might be able to find a video on YouTube that shows someone doing this.
Sorry for the late reply!
I have an openlabs Neko XXL. I thought the problem might have been software related..
So it seems, it was dust under the hood ;) I bought something called compuclean, which is a powerful compressed air blaster. It was 45 squid, but well worth it!!

Thanks for your help!! I can play without worry no more (apart from the neighbours ;) )
 
Ad

Advertisements

SeaGtGruff

I meant to play that note!
Moderator
Joined
Jun 6, 2014
Messages
2,744
Reaction score
1,153
I'm glad you were able to get the issue resolved! :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top