No sound on my Kurzweil SP3 after it heats up.

Discussion in 'Kurzweil Keyboards' started by MissElaine, Sep 6, 2016.

  1. MissElaine

    MissElaine

    Joined:
    Sep 6, 2016
    Messages:
    2
    Likes Received:
    0
    Hello everyone,

    My Kurzweil lately has been not making any sound after it's been on a while. Everything lights up, but there's just no sound. I can shut it down for about 15 minutes and it will work again, just until it gets warm, then I lose all sounds again. I did a concert over the weekend and just before the sound went out, the sustaining pedal stopped working. I unplugged it and plugged it back in and it wouldn't release, then all of the sounds stopped. Has anyone ever experienced this or have any idea what it could be. I have another concert coming up and I hope that I can use it. Thanks in advance for your help.
     
    MissElaine, Sep 6, 2016
    #1
    1. Advertisements

  2. MissElaine

    happyrat1 Destroyer of Eardrums!!!

    Joined:
    May 30, 2012
    Messages:
    4,677
    Likes Received:
    1,405
    Location:
    GTA, Canada
    It needs to be serviced by a qualified tech. Possibly a power transistor in the power supply or driver circuitry is overheating and needs to be replaced.

    This is not a simple DIY fix for most people.

    Gary ;)
     
    happyrat1, Sep 6, 2016
    #2
    1. Advertisements

  3. MissElaine

    MissElaine

    Joined:
    Sep 6, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks Gary, I was thinking the same thing about a technician. My husband thinks it could be a thermocoupler or maybe the fan.
     
    MissElaine, Sep 6, 2016
    #3
  4. MissElaine

    happyrat1 Destroyer of Eardrums!!!

    Joined:
    May 30, 2012
    Messages:
    4,677
    Likes Received:
    1,405
    Location:
    GTA, Canada
    My Kurzweil PC3K8 has no fan. It's possible a design as old as an SP3 might have one but I doubt it.

    Like I said, my guess is the power supply overheating and going into thermal cutoff.

    Gary ;)
     
    happyrat1, Sep 6, 2016
    #4
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Hueyduck
    Replies:
    3
    Views:
    323
    nickm
    Aug 30, 2008
  2. Organfreak

    Track Inspector- MIA, SP3.1

    Organfreak, Aug 23, 2004, in forum: cakewalk.audio
    Replies:
    4
    Views:
    257
  3. kitekrazy

    XP SP3

    kitekrazy, May 6, 2008, in forum: cakewalk.audio
    Replies:
    26
    Views:
    899
    Glennbo
    May 20, 2008
  4. Phoenix

    M-Audio XP SP3 drivers out

    Phoenix, Jul 2, 2008, in forum: cakewalk.audio
    Replies:
    10
    Views:
    472
    max rock
    Jul 8, 2008
  5. Ricky Hunt

    SP3

    Ricky Hunt, Oct 17, 2008, in forum: cakewalk.audio
    Replies:
    22
    Views:
    758
    Gerry Peters
    Oct 23, 2008
  6. 4tkStudios
    Replies:
    4
    Views:
    482
    4tkStudios
    Jul 8, 2016
  7. Dan in Illinois

    PX 110 no on board audio

    Dan in Illinois, Jul 26, 2016, in forum: Casio Keyboards
    Replies:
    4
    Views:
    336
    happyrat1
    Jul 26, 2016
  8. Narayana Rao

    No sound from keyboard built-in speakers

    Narayana Rao, Dec 9, 2016, in forum: Yamaha Keyboards
    Replies:
    2
    Views:
    239
    happyrat1
    Dec 10, 2016
Loading...