Roland fantom how to stop patch cutoff sound when in live settings play mode

Joined
Mar 20, 2018
Messages
1
Reaction score
0
I have been playing Live and find it so annoying and unprofessional that when switching created sounds in live setting play mode there is a sound cutout, for such an advanced instrument, this should be able to be fixed but Am yet to find a solution. Please help.
 
A

Advertising

A

Advertising

Joined
Mar 8, 2018
Messages
2
Reaction score
0
Hi Matt,

I have a Roland RD-2000 and this keyboard does have smooth sound transition. Maybe the Fantom doesn't have that feature.
In that case, there is a simple workaround you can use: simply use a second pedal unit (expression, etc.), assigned to control volume, and 1) smoothly fade out the volume using the pedal, 2) change to the other sound as you smoothly raise the volume again with the pedal.
 
Joined
Nov 16, 2012
Messages
425
Reaction score
111
Matt

What you are describing is known as Roland's "Patch Remain" technology. They introduced it in 1996 on their XP-80 ROMpler workstation and eventually carried it over to their other keyboard and tone module models. It is an optional "system" setting, and as far as I know, OFF by default on all of these devices. You have to manually turn it ON. See "Patch Remain" under "System Function" at the top of the right hand column on Page 179 of the Fantom manual. Also see the "Note" associated with this section. This is a caveat that applies to ALL of these Roland units, as well as ALL competitive models, that also now include a similar feature. If Patch Remain is active, and the "outgoing" tone uses effects settings, but the "incoming" tone does NOT use the exact same effect with exactly the same settings on ALL effects parameters, then there can still be a glitch when the tone is changed. If this is a problem in your case, then you may want to use the suggestions of CowboyNQ or Vadesriux, above. Personally, I prefer the split keyboard method, if your playing style and current piece being played allow you the keyboard space to do so.
 
Last edited:
Joined
Jul 3, 2016
Messages
9
Reaction score
0
I have been playing Live and find it so annoying and unprofessional that when switching created sounds in live setting play mode there is a sound cutout, for such an advanced instrument, this should be able to be fixed but Am yet to find a solution. Please help.
Use patch sounds , if you use performance sounds you may face this sound cut problem
 
Joined
Apr 5, 2017
Messages
12
Reaction score
2
On the Roland clan forum you can find a good workaround that I used for a few years on my Fantom, that uses the soft pads (drum pads) for voice presets to smoothly change ‘on the fly’ during performance. I don’t remover the detail as I retired it to the studio (it’s a mammoth!) and gig with a much lighter RD DP. But it works nicely. The Roland clan forum has been most helpful with ideas like this. Cheers!
 
A

Advertising

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top