Sound but no Volume cntrl on Casio PX-110


Joined
Aug 31, 2019
Messages
1
Reaction score
0
Hello,

I am new to this forum, am hoping someone can help with a suggestion on how to resolve the issue I'm experiencing with my Casio PX-110. The piano will turn on, keys can be heard, sound does come out of the speakers, however the Volume Pot will not increase or decrease the volume at all. Volume seems fixed at one level. Any suggestions on what could be the cause, as well what steps I could take to resolve the issue myself, I'm a experienced solderer, I've a multi-meter but dont know where I should begin to test with it.
 
Ad

Advertisements

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
8,106
Reaction score
3,403
Location
GTA, Canada
The logical place to start is to test the volume potentiometer to see if it is up to spec or not.

You may have to remove it from circuit to test it properly.

Gary ;)
 
Joined
Sep 6, 2017
Messages
1,836
Reaction score
1,242
Location
Lancashire, UK.
Welcome.

Does the volume knob move?

If it does try removing it if you can and gently try to rotate the spindle.

Opening up the keyboard and a quick squirt of contact cleaner into the potentiometer could loosen up the rotating contact if it has stuck.
 
Ad

Advertisements

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
8,106
Reaction score
3,403
Location
GTA, Canada
Actually trace the circuit leading to the pot. There may be a fractured or cold solder joint taking it out of the circuit.

Gary ;)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top