Kurzweil K2600X powers up - patches appear loaded - but no sound

Joined
Mar 5, 2021
Messages
19
Reaction score
1
Anyone had experience with a Kurzweil K2600X that powers up fine and display shows all the patches are loaded but there is no sound when playing the keys? I purchased one used today with only a few piano sounds that worked and put out sound. I did a hard reset and , now, none of the patches are making any sound. checked the main volume slider - headphone jack out worked before the hard reset. not sure where to start looking.

Thanks,
Sunny
 
Joined
Apr 4, 2012
Messages
1,575
Reaction score
741
try reinstalling the operating system. It should take less than 5 minutes to do. This way everything is clean. Save your user data as an operating system reload blows away user data.
 
Joined
Jan 13, 2022
Messages
3
Reaction score
0
Tried it @delaware dave but still no sound. Tried installing RAM-objects as well. All diagnostics fine and everything seems to be working. Except for no sound out on any of the jack outputs or headphones. Other thoughts?
 
Joined
Apr 4, 2012
Messages
1,575
Reaction score
741
It could be many issues; all theoretical because we cant see nor touch the keyboard. If your car doesn't start, how many things could cause that? At least 20 that I can think of; but without popping the hood and eliminating some of those issues it's purely speculation. And since he hasn't logged onto this site in over 1 year I don't think we'll be hearing from him again.
 
Joined
Apr 28, 2022
Messages
2
Reaction score
0
It could be many issues; all theoretical because we cant see nor touch the keyboard. If your car doesn't start, how many things could cause that? At least 20 that I can think of; but without popping the hood and eliminating some of those issues it's purely speculation. And since he hasn't logged onto this site in over 1 year I don't think we'll be hearing from him again.
I think I would have done better taking my K2600rs to my GMC dealer than the Kurzweil Authorized Repair Person who had that unit and a K2500rs for 15 months and did nothing, before handing back one in pieces and the other unrepaired.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
14,109
Messages
87,185
Members
13,177
Latest member
sfz5

Latest Threads

Top