Yamaha PSR 520 didn't sent Note off signal to the computer

Joined
Aug 30, 2021
Messages
2
Reaction score
0
Hello, I have a problem here. I have an old Yamaha PSR 520 keyboard. I buy a usb to midi cable and connect the keyboard to my computer.

The keyboard is detected by my computer. But I can't press keys on my keyboard directly one after another.

I launch MIDI-OX program and analyze that my Yamaha PSR 520 didn't sent Note off signal to the computer right after sending Note On signal, so I can't play notes one by one smoothly or even play a chord.

What was the problem? Please help. This is the link to my youtube video about this:
 
Last edited:

SeaGtGruff

I meant to play that note!
Moderator
Joined
Jun 6, 2014
Messages
4,110
Reaction score
1,736
Are you having the problem even if the keyboard isn't connected to the computer, or does it function correctly when played on its own?

If the keyboard seems to function correctly on its own, then it's possible that the MIDI-to-USB interface cable you purchased is unreliable. If feasible, try to use an interface cable that's been found to be more reliable with MIDI-only keyboards, such as the mio from iConnectivity.
 
Joined
Aug 30, 2021
Messages
2
Reaction score
0
Yes, if keyboard isn't connected to the computer, it can function properly.

Yes, I assume the midi-to-usb interface cable is unreliable. Below is the cable. No brand.

Thanks for the advice for which interface is good.
 

Attachments

  • aa9665b50428dd7c2b7bd4032f684013.jpg
    aa9665b50428dd7c2b7bd4032f684013.jpg
    78.7 KB · Views: 23

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,042
Messages
86,613
Members
13,145
Latest member
richardtrifan

Latest Threads

Top