Korg I3 Volume Problem?....pls help


Joined
Feb 13, 2016
Messages
4
Reaction score
1
Hi all,

Iv got a Korg i3 that was suffering from a scratchy master volume slider pot... When moving the slider it produces a scratching noise when moved and then the output from the keyboard totally cuts out 2/3rds from the faders travel..I ordered a replacement and fitted it the other day and im having exactly the same problem..A similar thing happened to an allen & heath dj mixer I had and it turns out it was a bad ground... Could anyone help me with this or point me in the right direction? bad coupling cap maybe? its also the same on the headphone output...but even weaker
 
Ad

Advertisements

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
8,002
Reaction score
3,354
Location
GTA, Canada
It's possible that the replacement part was sitting on a shelf so long that it oxidized as well.

First thing I would try is squirting in a liberal amount of contact cleaner and working the pot back and forth to see if that clears up the problem.

If that fails, then I'd start looking for bad electrolytic caps and marginal semiconductors and cold solder joints in the output stages.

Actually a bad solder joint is the next most likely culprit in the list.

Then caps.

Then semis.

Gary ;)
 
Joined
Feb 13, 2016
Messages
4
Reaction score
1
Cheers Gary, Aye iv tried giving it a squirt of isopropyl, I doubt its the replacement fader (which cost £30 cos I had to order from the US) as its exactly the same problem as the last one...theres only a few big electrolytics for the mute circuit which iv checked, everything else is pretty much surface mount stuff, iv reflowed most of the big solder joints and checked continuity with a DMM along with the wiring looms.... literally pulling my hair out!
 

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
8,002
Reaction score
3,354
Location
GTA, Canada
My guess is that either you've missed a dodgy solder joint somewhere or it's a dying electrolytic cap somewhere

If you can get your hands on an ESR meter you can check out the caps in circuit. Otherwise you'd have to desolder a leg on every cap you test.

Otherwise test of last resort is start checking the audio stage transistors and op amps.

You might also be able to pinpoint the problem by powering up the circuit and tapping some physical vibration on the components to identify the noisy one. Could be a dodgy internal lead on a cap or resistor.

Gary ;)

.
 
Joined
Feb 13, 2016
Messages
4
Reaction score
1
it was servisol contact cleaner I was using... Ok cheers gary, thanks so much for the advice, I'll crack it open again tomorrow and have another blast
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top