Yamaha ypg 635 left speakers not working

Joined
Sep 16, 2023
Messages
1
Reaction score
0
hi, I recently got a yamaha ypg 635 given to me and I noticed the left speakers are not working. I have reset the keyboard and I don't see any kind of balance setting for this model. maybe the amp board is toast? just wondering if anyone might have any idea's?
thanks
 

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
14,025
Reaction score
5,612
Location
GTA, Canada
It could also be as simple as a a dirty volume potentiometer. Try a squirt of Deoxit in the volume control.
 

Rayblewit

Love Music / Love Life
Joined
Nov 18, 2015
Messages
3,001
Reaction score
2,272
Location
Melbourne Australia
Does Deoxit have a long use by date?
It is very expensive! Especially since you only need a little squirt.
Is there another substitute product? Cheaper maybe?
 

happyrat1

Destroyer of Eardrums!!!
Joined
May 30, 2012
Messages
14,025
Reaction score
5,612
Location
GTA, Canada
It can sit in the can forever as long as it stays pressurized. Other cheaper contact cleaners are out there but it can be a crap shoot.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,194
Messages
87,967
Members
13,215
Latest member
pcmtech

Latest Threads

Top